Home > BGP Sim

BGP Sim

February 4th, 2019 Go to comments

Question

Loopback0 is used for IBGP peering while physical interface address is used for EBGP. Identify the IBGP issues on R1 to R2, R3 and EBGP issues to RA and fix them so that the “show ip bgp” command on R1 will display all loopback interfaces of other routers.

Special thanks to Madruga who created this BGP simlet with EVE-NG emulator and you can download it here.

Configs on R1:

This lab is for BGP only so we only need to check BGP section

R1#show running-config
—-output omitted—-
router bgp 64520
network 172.16.1.1 mask 255.255.255.255
neighbor IBGP peer-group
neighbor IBGP remote-as 64550
neighbor IBGP update-source loopback0
neighbor 172.16.2.2 peer-group IBGP
neighbor 172.16.3.3 peer-group IBGP
neighbor 209.165.200.2 remote-as 64525

—-output omitted—-

Solution

We see there are two issues here (two commands in bold), the first one is IBGP issue and the second one is EBGP issue.

R1(config)#router bgp 64520
R1(config-router)#neighbor IBGP remote-as 64520
R1(config-router)#no neighbor 209.165.200.2 remote-as 64525
R1(config-router)#neighbor 209.165.201.2 remote-as 64525

Note:
+ In the second statement we fix the IBGP group to “remote-as 64520” without removing the wrongly configured IBGP group (“neighbor IBGP remote-as 64550”) because if we remove this statement, other related statements of IBGP (three statements “neighbor IBGP update-source Loopback0”, “neighbor 172.16.2.2 peer-group IBGP”, “neighbor 172.16.3.3 peer-group IBGP”) will be removed automatically because IBGP group no longer exists.
+ Also in statement 2 the “IBGP” group must be written in capital. You will receive an error if writing it in lowercase.
+ The IP addresses in the exam are different but the concept is still the same so please read the question carefully

After solving the problem don’t forget to verify with the “show ip bgp” command. You must see all the Loopback interfaces of other routers. Otherwise please check your commands again.

Comments (28) Comments
  1. @Pusheen
    January 9th, 2020

    Are you talking about the simlet on NetworkTut? You can’t enter any config commands here.

  2. morarica
    January 12th, 2020

    can anyone use the simlet from madriga? i cannot start the routers.

  3. Saji
    January 14th, 2020

    @ ItsShowtime,,,,

    How many lab sim that we should change the config on real exam??
    or Aren’t we suppose the change the config at all as networktut webside says.?

  4. Daveado
    January 15th, 2020

    I’ve tried this and the HSRP simlet in EVE-NG and for both or them none of the devices have any config. The topology is there and all the interfaces are connected, but there’s only default config on all devices?

    Anyone else had this issue and been able to fix?

  5. Bryan
    January 16th, 2020

    Hi, Passed Tshoot exam last monday(1/13/2020) and Finally completed 3 exams(Routing,Switching and Tshoot). All question and tickets from this site are valid. If you want dumps and materials I can share them with you just shoot email bryandiazbd430 @ gmail .com :)

  6. Stan
    January 17th, 2020

    Where can I get simplets initial configs ?

  7. Jenny_chey
    January 21st, 2020

    Does anyone have a working lab on this?

    Thanks,
    Jen

  8. Anonymous
    January 25th, 2020

    R1(config)#router bgp 64520
    R1(config-router)#neighbor IBGP remote-as 64520
    R1(config-router)#no neighbor 209.165.200.2 remote-as 64525
    R1(config-router)#neighbor 209.165.201.2 remote-as 64525

    Wr and copy ru start Works on this sim ???? to save the config….

  9. Stan
    January 26th, 2020

    Just passed 923, messed up an IP ticket I think… everything is valid still, probably will be till 23rd… Anyone need material hit me up at yoz[@]gmx.us

  10. Wr and copy ru start Works on this sim ???? to save the config
    January 30th, 2020

    Wr and copy ru start Works on this sim ???? to save the config

  11. Erice77777
    February 2nd, 2020

    itook the exam yestarday and i scored 702
    the problem is when i answer the 3rd question of a tikcet and i return back to previous question (2nd question) and then i go agan to next question (the third question) i found that the question (third quetion has changed.
    is there anyone who ,faced the same issue ??
    is it a bug ??

  12. Ghost
    February 2nd, 2020

    @Erice77777 3rd will never change, it all depends on 1st & 2nd choice.

  13. Solid Snake
    February 5th, 2020

    In the BGP simlet, the configuration I saw was the following:

    R1 # show ip bgp summary

    172.16.2.2 64550
    172.16.3.3 64550
    209.165.227.2 64525

    Therefore the valid configuration would be the following:

    Router # configure terminal
    Router (config) #router bgp 64520
    Router (config-router) #neighbor IBGP remote-as 64520
    Router (config-router) #no neighbor 209.165.227.2 remote-as 64525
    Router (config-router) #neighbor 209.165.201.2 remote-as 64525

    – This would be the correct configuration, right?

    On the other hand, I don’t let myself write or copy startup-config running-config!

    – Is this normal?

    I will greatly appreciate your answers to my questions.

    Thanks!

    Regards.

  14. A happy CCNP
    February 5th, 2020

    Passed the exam today with 925! Pay the premium membership, then you will be able to see the Multiple choice questions and get access to the ticket online simulator! Everything is the same in the exam. The only questions on the exam are the november questions. Thank you so much networktut. this was my last exam, i’m a CCNP!! Im so happy!

  15. GTH
    February 6th, 2020

    Hello all,

    why do we need to enter the “neighbor IBGP remote-as 64520” and not “neighbor IBGP remote-as 64525” as the AS of the remote seems to be 64525 on the picture ?

  16. Stan The Man
    February 7th, 2020

    @GTH
    The ‘remote-as’ refers to the AS, and since this is in reference to the peer-group IBGP (internal BGP neighbors) it should be 64520.
    For the neighbor statements in the different AS, ‘remote-as’ refers to 64525

    Hope this helps!

  17. KingShrek
    February 8th, 2020

    @Solid Snake

    Its normal that you cant do a “write mem” in the premium simulator. They just “cook” something to adapt. Just check if yre putting all the correct comands and also get the idea.

  18. ayman
    February 12th, 2020

    Hy guys I can’t find the configuration of this simlet and olso for HSRP simlet
    Thanks in advance:)

  19. GreenMonkey
    February 14th, 2020

    I want to build the BGP simlet lab.Can anyone who has installed the EVE-NG emulator share the configuration files with me. I am planning on doing the Exam very shortly and just want to play around. Any help will be greatly appreciated. Thanks

  20. BGP simlet
    February 14th, 2020

    On the BGP sim here on Networktut, when you do “sh ip bgp sum”, the iBGP adjacencies are up, even though the remote ASN is incorrect. But if you do “sh ip bgp”, only R1’s loopback is seen. Also, after submitting the correct fixes, neither output changes. Is that so in the real exam, too? Thanks.

  21. Anonymous
    February 16th, 2020

    Boa noite á todo… gostaria de saber sobre o LAB BGP …. é o mesmo que está aqui no site ?

  22. AJ
    February 17th, 2020

    I am going for TShoot on 19th … Are all sims same and mcq same?

  23. marcus
    February 19th, 2020

    @AJ , tell us ! did you pass the exam?
    are the Multiple Choice Questions are valid?

  24. TT
    February 20th, 2020

    Yes, all MCQs Nov. updates, ticket and simlet are valid. The only extra thing I had in my exam early this week was the BGP Simlet; one of the requirement is to get the EBGP routers RA & RB up and show in the BGP Summary command in addition to what is already illustrated in the BGP Simlet…. Good Luck!

  25. CSG
    February 20th, 2020

    All are here 100% passed with 1000 score today.

  26. Passed just now
    February 22nd, 2020

    Everything from november mcq. Sim and lab are same as on the site. 1000/1000

  27. WTF
    February 22nd, 2020

    Passed 1000/1000. Thanks!

  28. heloo
    September 10th, 2020

    send full config

vceplus-200-125    | boson-200-125    | training-cissp    | actualtests-cissp    | techexams-cissp    | gratisexams-300-075    | pearsonitcertification-210-260    | examsboost-210-260    | examsforall-210-260    | dumps4free-210-260    | reddit-210-260    | cisexams-352-001    | itexamfox-352-001    | passguaranteed-352-001    | passeasily-352-001    | freeccnastudyguide-200-120    | gocertify-200-120    | passcerty-200-120    | certifyguide-70-980    | dumpscollection-70-980    | examcollection-70-534    | cbtnuggets-210-065    | examfiles-400-051    | passitdump-400-051    | pearsonitcertification-70-462    | anderseide-70-347    | thomas-70-533    | research-1V0-605    | topix-102-400    | certdepot-EX200    | pearsonit-640-916    | itproguru-70-533    | reddit-100-105    | channel9-70-346    | anderseide-70-346    | theiia-IIA-CIA-PART3    | certificationHP-hp0-s41    | pearsonitcertification-640-916    | anderMicrosoft-70-534    | cathMicrosoft-70-462    | examcollection-cca-500    | techexams-gcih    | mslearn-70-346    | measureup-70-486    | pass4sure-hp0-s41    | iiba-640-916    | itsecurity-sscp    | cbtnuggets-300-320    | blogged-70-486    | pass4sure-IIA-CIA-PART1    | cbtnuggets-100-101    | developerhandbook-70-486    | lpicisco-101    | mylearn-1V0-605    | tomsitpro-cism    | gnosis-101    | channel9Mic-70-534    | ipass-IIA-CIA-PART1    | forcerts-70-417    | tests-sy0-401    | ipasstheciaexam-IIA-CIA-PART3    | mostcisco-300-135    | buildazure-70-533    | cloudera-cca-500    | pdf4cert-2v0-621    | f5cisco-101    | gocertify-1z0-062    | quora-640-916    | micrcosoft-70-480    | brain2pass-70-417    | examcompass-sy0-401    | global-EX200    | iassc-ICGB    | vceplus-300-115    | quizlet-810-403    | cbtnuggets-70-697    | educationOracle-1Z0-434    | channel9-70-534    | officialcerts-400-051    | examsboost-IIA-CIA-PART1    | networktut-300-135    | teststarter-300-206    | pluralsight-70-486    | coding-70-486    | freeccna-100-101    | digitaltut-300-101    | iiba-CBAP    | virtuallymikebrown-640-916    | isaca-cism    | whizlabs-pmp    | techexams-70-980    | ciscopress-300-115    | techtarget-cism    | pearsonitcertification-300-070    | testking-2v0-621    | isacaNew-cism    | simplilearn-pmi-rmp    | simplilearn-pmp    | educationOracle-1z0-809    | education-1z0-809    | teachertube-1Z0-434    | villanovau-CBAP    | quora-300-206    | certifyguide-300-208    | cbtnuggets-100-105    | flydumps-70-417    | gratisexams-1V0-605    | ituonline-1z0-062    | techexams-cas-002    | simplilearn-70-534    | pluralsight-70-697    | theiia-IIA-CIA-PART1    | itexamtips-400-051    | pearsonitcertification-EX200    | pluralsight-70-480    | learn-hp0-s42    | giac-gpen    | mindhub-102-400    | coursesmsu-CBAP    | examsforall-2v0-621    | developerhandbook-70-487    | root-EX200    | coderanch-1z0-809    | getfreedumps-1z0-062    | comptia-cas-002    | quora-1z0-809    | boson-300-135    | killtest-2v0-621    | learncia-IIA-CIA-PART3    | computer-gcih    | universitycloudera-cca-500    | itexamrun-70-410    | certificationHPv2-hp0-s41    | certskills-100-105    | skipitnow-70-417    | gocertify-sy0-401    | prep4sure-70-417    | simplilearn-cisa    |
http://www.pmsas.pr.gov.br/wp-content/    | http://www.pmsas.pr.gov.br/wp-content/    |